Maksiulek

Problem z sslforfree

Polecane posty

Powitać. Od jakiegoś czasu używałem certyfikatu Let's Encrypt generowanego na www.sslforfree.com. Od czwartku walczę z błędami. Nie mogę wygenerować nowego certyfikatu dla żadnej z moich domen. Weryfikacja przez FTP, wrzucam pliki, po kliknięciu na link pobiera mi je i przy generce mam taki kwiat.

 

Cytat

Domain "www.domena.com" challenge3 failed. Response from "https://acme-v01.api.letsencrypt.org/acme/challenge/N3onVbe6QaQ5BCIpdlXq-YUqvVYwZH1Lx9cA3C7-zHc/2565807650" was: { "type": "http-01", "status": "invalid", "error": { "type": "urn:acme:error:connection", "detail": "Fetching http://domena.com/.well-known/acme-challenge/fvwJ0dty8sc6uv1-lmBCYzsVCo9iPyl-DGhClIhlA9A: Timeout", "status": 400 }, "uri": "https://acme-v01.api.letsencrypt.org/acme/challenge/N3onVbe6QaQ5BCIpdlXq-YUqvVYwZH1Lx9cA3C7-zHc/2565807650", "token": "fvwJ0dty8sc6uv1-lmBCYzsVCo9iPyl-DGhClIhlA9A", "keyAuthorization": "fvwJ0dty8sc6uv1-lmBCYzsVCo9iPyl-DGhClIhlA9A.GhSfx0a_W8sSwWG2bEbJ8Poy36VMGA229DrGoqVAEtU", "validationRecord": [ { "url": "http://domena.com/.well-known/acme-challenge/fvwJ0dty8sc6uv1-lmBCYzsVCo9iPyl-DGhClIhlA9A", "hostname": "domena.com", "port": "80", "addressesResolved": [ "188.116.20.9", "2a02:ee0:3::1:10" ], "addressUsed": "2a02:ee0:3::1:10", "addressesTried": [] } ] }

 

Jakieś pomysły ? Tworzyłem nowe konto nawet na sslforfree, ale dalej to samo.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

wyłącz na chwilę przekierowania czyli pogrzeb w htaccess lub zmień na chwilę nazwę i zobacz czy się wygeneruje


dymna.jpg

Przyjaźń psa na całe życie. ZAGINĄŁ DOM

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Niestety, ani jego zmiana nazwy, by był widoczny tylko jako plik, ani jego całkowite usunięcie nie rozwiązuje problemu. Dalej to samo.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Masz timeout, więc sprawdź, czy to firewall Ci nie wycina połączenia.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Żadnego firewalla nie stawiałem, nie mam wtyczki nawet o niego opartej. Zresztą wyłączałem i je wszystkie. Dalej to samo.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Spróbowałbym podpytać support hekko, czy ich firewall nie blokuje połączeń od letsencrypt.

A Twoja strona działa poprawnie po IPv6?

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Dowcip był taki że działało od dawna wszystko, teraz w czwartek się wykrzaczyło i walczę z tym. Jak nic nie da, to popytam ich, ale nie liczą na pomoc. W zasadzie ich wsparcie nigdy mi nie pomogło. A to IP v6 jak sprawdzić ? Bo ja zielony w tym temacie.

Edytowano przez Maksiulek

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Hekko na współdzielonym nie obsługuje Let's Encrypt. Taką informację dostałem od ichniego BOK 3 miesiące temu gdy próbowałem sobie zainstalować ten certyfikat. No chyba, że to się od tamtego czasu zmieniło, ale nie sądzę, bo naganiali mnie na VPS i płatny SSL od nich.


Tani hosting z darmowym certyfikatem SSL HEXCORE

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

No IPv6 connectivity :-(
@ttah, naganiali. Od dawna miałem darmowe szyfrowanie, tylko teraz po przejęciu przez h88 i pracach konserwacyjnych na serwerach coś się zaczęło knocić. Czas odpowiedzi serwera jest tragiczny, o czym była mowa w innym temacie. Później zobaczę jeszcze jeden sposób z nową domeną. A nóż widelec... Oczywiście wszelkie uwagi mile widziane.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Nie no, Let's encrypt jest niedostępne z poziomu DA, ale jak wygenerujesz sobie cert gdzieś indziej, to możesz go wkleić wszędzie.

Wygląda to na problem z IPv6, bo zobacz:

"addressesResolved": [ "188.116.20.9", "2a02:ee0:3::1:10" ], "addressUsed": "2a02:ee0:3::1:10"

A zwłaszcza:

"addressUsed": "2a02:ee0:3::1:10"

 

@Maksiulek podeślij domenę na PM. Zerknę co tam się dzieje.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
14 godzin temu, ttah napisał:

Hekko na współdzielonym nie obsługuje Let's Encrypt

Polecam np http://blutu.pl/

oferuje Let's Encrypt


banerred23new.png

HTTP 200 usługi IT - Dariusz Janicki | Realizacja serwisów www oraz oprogramowania.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Bądź aktywny! Zaloguj się lub utwórz konto

Tylko zarejestrowani użytkownicy mogą komentować zawartość tej strony


  • Kto przegląda   0 użytkowników

    Brak zalogowanych użytkowników przeglądających tę stronę.