Jump to content

Warning line 286


Recommended Posts

Witam wszystkich,

Mam taki problem. Jestem w trakie robienia kursu
Warning: Parameter 2 to title_like_posts_where() expected to be a reference, value given in D:\xampp\htdocs\lovetoeat\wp-includes\class-wp-hook.php on line 286

Info jakie znalazłem, to że moga byc problemy z pluginami-wyłączone wszystkie.
kolejne to aby define( ‚WP_DEBUG’, true ); zmienic na define( ‚WP_DEBUG’, false ); – zrobione i cały czas ten sam error.

Link to post
Share on other sites
21 godzin temu, Konrad2019 napisał:

Info jakie znalazłem, to że moga byc problemy z pluginami-wyłączone wszystkie.

Pamiętaj, że pluginy powstawały od dawien dawna jeszcze dla php 5 x, a teraz mamy php 7.x, więc mogą być niekompatybilne dla Twojej wersji PHP.

 

HTTP 200 usługi IT - Dariusz Janicki | Realizacja serwisów www oraz oprogramowania w PHP / C# / Golang / Node.js / MySQL
- Full Stack Developer - :chatownik:

 

Link to post
Share on other sites

Błąd pojawił sie w trakcie robienia kursu. Ja jestem początkujący. Wszystko działało dobrze więc olałem temat. Teraz zaczynają się problemy.

 

Pluginy mam tylko obecne, także tu nie powinno byc problemu.

 

Zastanawiam się, czy jakieś funkcje mogą powodować ten błąd. Na wstępie kursu było powiedziane, że niektóre funkcje z nowszymi wersjami php moga nie działać.

Kurs jest dość stary. Wer WP to 3,2.

Link to post
Share on other sites

WP 7 zanim wyjdzie, to wody upłynie sporo, o wer. 11 już nawet nie mówię. Na tematy kodowania, nie odpowiem bo nie siedzę w tym głęboko, a druga sprawa, nie wiadomo co wymyślą twórcy. Myślał indyk o niedzieli...

 

Nic konkretnego nie polecę, bo sam nie korzystam z tych poradników. Ale w google tego pełno :

https://www.sitepoint.com/build-wordpress-theme-from-scratch-basics/

 

 

 

Możesz też polować za darmowymi kursami na UDEMY, co jakiś czas wrzucają jakiś darmowe oferty.

Doświadczone i pewne Biuro Rachunkowe w Łodzi. Na rynku od 1995 roku ! 

Blog księgowego, czyli nowe przepisy podatkowe opisane prostym językiem.

Link to post
Share on other sites

PHP 5.6 oraz 7.0.x nie sa wspierane. Wersja 7.1.x będzie otrzymywała poprawki do 1 grudnia 2019 roku a wersja 7.2 będzie otrzymywała poprawki do 30 listopada 2020 roku.
Wiec jak już się bawisz w coś w PHP to rób to na aktualnym oprogramowaniu, a nie sprzed 8 LAT.

HTTP 200 usługi IT - Dariusz Janicki | Realizacja serwisów www oraz oprogramowania w PHP / C# / Golang / Node.js / MySQL
- Full Stack Developer - :chatownik:

 

Link to post
Share on other sites
  • 3 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Terms of Use Privacy Policy