morelo

Przeniesienie sklepu do home - Drupal

11 postów w tym temacie

Witam przenieśliśmy od innego usługodawcy do home i zaczęły się problemy mianowicie, zdjęcia do podglądu towaru się nie wyświetlają.

 

druga sprawa
Zamówienia które przychodzą się nie otwierają i nie zapisują przychodzi tylko mail. 

od starego usługodawcy dostałem info
Proszę przy przenoszeniu sklepu na home zwrócić uwagę, że jest on opary o autorskie rozwiązanie – nie jest to typowy serwer apache. Mają zupełnie inne reguły przepisywanie linków oraz domyślnie jest tam ustawione php w wersji 5.2.

Prosze o pomoc

 

rk432_zdjecie.jpg

Udostępnij tego posta


Odnośnik do posta
Udostępnij na stronach

Jeśli masz dostęp do logów, to zerknij tam. Ustaw php 5.5 lub 5.6 i zobacz, czy problem nadal występuje. Sprawdź uprawnienia plików i katalogów.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na stronach
1 godzinę temu, swits.pl napisał:

Jeśli masz dostęp do logów, to zerknij tam. Ustaw php 5.5 lub 5.6 i zobacz, czy problem nadal występuje. Sprawdź uprawnienia plików i katalogów.

na home to inaczej działa trochę ale wszystko jest w pomocy razem z przykładami jak zrobić, wystarczy poczytać :)

Udostępnij tego posta


Odnośnik do posta
Udostępnij na stronach

Php jest 5,6  pliki katalogi 777 problem nadal jest, hm wydaje mi się ze to będzie coś w pliku htaccess

ktoś jest w stanie pomóc jeszcze doradzić?

Udostępnij tego posta


Odnośnik do posta
Udostępnij na stronach

Ustaw 755 dla katalogów, 644 dla plików. I sprawdź logi, tam znajdziesz podpowiedź.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na stronach

Napisano (edytowane)

było 755 i 644 tak na początku i to samo w koło, logi co dokładnie?

kayman

o czym piszesz?

home mi tyle odpisalo

Z przeprowadzonej weryfikacji wynika, że Państwa skrypt niepoprawnie linkuje do zasobów serwera. Przykładowo dla jednego z produktów skrypt próbuje wczytać zdjęcie z zasobu: www.zzzzzz.com.pl/%20http%3A/%252Fwww.zzzzzz.com.pl/sites/default/files/imagecache/product_full_watermark/sandow_wiz__igor_k-41-bp_a__wenge_alcantarra213_1.jpg co jest niepoprawnym adresem, a dopiero www.zzzzzz.com.pl/sites/default/files/imagecache/product_full_watermark/sandow_wiz__igor_k-41-bp_a__wenge_alcantarra213_1.jpg działa poprawnie, w związku z czym nalezałoby w taki sposób zmodyfikować skrypt, aby nie dodawał podwójnie adresu strony.

Edytowane przez morelo

Udostępnij tego posta


Odnośnik do posta
Udostępnij na stronach

Na home.pl jest problem z kompresją gzip

rzuć okiem na htacces:

# Serve gzip compressed CSS files if they exist and the client
accepts gzip

Udostępnij tego posta


Odnośnik do posta
Udostępnij na stronach

cała konfiguracja migracji dowolnego softu na home

- przenoszę soft

- przenoszę bazę

- w sofcie zmieniam login/hasło do bazy

- w pliku htaccess wpisuję interesującą mnie wersję php

Udostępnij tego posta


Odnośnik do posta
Udostępnij na stronach

@kayman Pamiętaj jeszcze o ścieżkach, które również mogły się zmienić, a niektóre skrypty są na to wrażliwe ;)

Udostępnij tego posta


Odnośnik do posta
Udostępnij na stronach
3 godziny temu, swits.pl napisał:

Pamiętaj jeszcze o ścieżkach, które również mogły się zmienić, a niektóre skrypty są na to wrażliwe

niezależnie od hosta jest raportowanie błędów, konsola lub ktoś kto wie o co chodzi :)

Udostępnij tego posta


Odnośnik do posta
Udostępnij na stronach
22 godziny temu, kayman napisał:

lub ktoś kto wie o co chodzi :)

Ktoś kto wie o co chodzi za pomoc w przywróceniu działania na home bierze stawkę standardową (dla normalnych hostów) x 10 za ich autorskie rozwiązania i ideawebserwer ;)

Udostępnij tego posta


Odnośnik do posta
Udostępnij na stronach

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

Tylko zarejestrowani użytkownicy mogą dodawać komentarze

Dodaj konto

Dodaj nowe konto. To bardzo proste!


Zarejestruj nowe konto

Zaloguj się

Posiadasz już konto? Zaloguj się tutaj.


Zaloguj się teraz

  • Przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników, przeglądających tę stronę.