Jump to content
Sanchez Spinoza

Problem przekierowaniem 301

Recommended Posts

Mam mały problem z przekierowaniem 301 na stronie. Przeszedłem na SSL i nie działa mi poprawnie przekierowanie związane z podfolderem. 

Mianowicie gdy wpisze się adres:

https://www.strona.pl/blog/temat-artykulu/  

to wszystko działa poprawnie.

 

Ale gdy ktoś wpisze stary adres bez https czyli 

http://www.strona.pl/blog/temat-artykulu/  

to przekierowuje go na stronę https://... ale wycina nazwę /blog/ z linku czyli pozostaje postać:

https://www.strona.pl/temat-artykulu/  

przez co cała strona się wysypuje :/

 

W .htaccess  mam następujący zapis:

 

# BEGIN WpFastestCache
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{HTTPS} =on
RewriteCond %{HTTP_HOST} ^www.strona.pl
# Start WPFC Exclude
# End WPFC Exclude
# Start_WPFC_Exclude_Admin_Cookie
RewriteCond %{HTTP:Cookie} !wordpress_logged_in_[^\=]+\=admin
# End_WPFC_Exclude_Admin_Cookie
RewriteCond %{HTTP_HOST} ^www.
RewriteCond %{HTTP_USER_AGENT} !(facebookexternalhit|Twitterbot|LinkedInBot|WhatsApp|Mediatoolkitbot)
RewriteCond %{HTTP_USER_AGENT} !(WP\sFastest\sCache\sPreload(\siPhone\sMobile)?\s*Bot)
RewriteCond %{REQUEST_METHOD} !POST
RewriteCond %{REQUEST_URI} !(\/){2}$
RewriteCond %{REQUEST_URI} \/$
RewriteCond %{QUERY_STRING} !.+
RewriteCond %{HTTP:Cookie} !comment_author_
RewriteCond %{HTTP:Cookie} !woocommerce_items_in_cart
RewriteCond %{HTTP:Cookie} !safirmobilswitcher=mobil
RewriteCond %{HTTP:Profile} !^[a-z0-9\"]+ [NC]
RewriteCond %{DOCUMENT_ROOT}/wp-content/cache/all/$1/index.html -f [or]
RewriteCond /home/masif/domains/strona.pl/public_html/blog/wp-content/cache/all/blog/$1/index.html -f
RewriteRule ^(.*) "/blog/wp-content/cache/all/blog/$1/index.html" [L]
</IfModule>

<FilesMatch "index\.(html|htm)$">
AddDefaultCharset UTF-8
<ifModule mod_headers.c>
FileETag None
Header unset ETag
Header set Cache-Control "max-age=0, no-cache, no-store, must-revalidate"
Header set Pragma "no-cache"
Header set Expires "Mon, 29 Oct 1923 20:30:00 GMT"
</ifModule>
</FilesMatch>
# END WpFastestCache

<Files xmlrpc.php>
Order allow,deny
Deny from all
</Files>



# BEGIN rlrssslReallySimpleSSL rsssl_version[3.1.3]
<IfModule mod_rewrite.c>
RewriteEngine on
RewriteCond %{HTTPS} !=on [NC]
RewriteCond %{REQUEST_URI} !wp-content\/cache\/(all|wpfc-mobile-cache)
RewriteRule ^(.*)$ https://%{HTTP_HOST}/$1 [R=301,L]
</IfModule>
# END rlrssslReallySimpleSSL


# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /blog/
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /blog/index.php [L]
</IfModule>
# END WordPress

 

Czy ktoś mógłby na to rzucić okiem i pomóc?

Nie czuję się mocny w przekierowaniach :/ 


Profesjonalne publikacje Content Marketingowe - zamów online na BlackHood.pl 

Masz już własne konto na WhitePress

Polecam również Oferty pracy z Bielska-Białej

Share this post


Link to post
Share on other sites

Chyba rozwiązałem problem,

 

 

Zamiast:

 

RewriteRule ^(.*)$ https://%{HTTP_HOST}/$1 [R=301,L]

 

dałem:

 

RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

 

tak będzie poprawnie? Pytam bo działa :)


Profesjonalne publikacje Content Marketingowe - zamów online na BlackHood.pl 

Masz już własne konto na WhitePress

Polecam również Oferty pracy z Bielska-Białej

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Terms of Use Privacy Policy