Jump to content
Sign in to follow this  
tnw

Mapa xml a mode rewrite - problem

Recommended Posts

Witam

Mam taki problem. Generuje sitemapy w xml z kodowaniem iso-8859-2. W linku mam polskie znaki, np. ł w nazwie pliku. W mode rewrite mam warunek ^([A-Za-zł]+). Niestety widze ze googlak sobie nie radzi z takimi stronami, gdyż mam sporo 404, gdzie litera ł ma kod %C3%85. Normalnie, w adresie ze strony widze ł zakodowane jako %B3 i z tym mode rewrite sobie radzi. Pytanie jak teraz zakodować kod %C3%85 w mode rewrite ?

Dzięki i pozdrawiam

Share this post


Link to post
Share on other sites

1. Jeśli to tylko możliwe, radziłbym zamianę liter z ogonkami na bezogonkowe.

2. To raczej nie wina googlaka, tylko mod_rewrite. Możesz wkleić tu zawartość htaccess lub samą regułkę mod_rewrite, jeśli plik jest duży.

Podanie adresu strony też by ułatwiło sprawę.


Autor postu nie ponosi żadnej odpowiedzialności za ewentualne szkody wynikłe z wykorzystania zawartych w nim informacji.

Share this post


Link to post
Share on other sites

1. Jeśli to tylko możliwe, radziłbym zamianę liter z ogonkami na bezogonkowe.

chciałbym zachować polskie litery w urlu ze wzgledu na specyfike serwisu: Słownik krzyżówki Info, ale jezeli to bedzie az taki problem, to bede musial cos wymyslic

2. To raczej nie wina googlaka, tylko mod_rewrite. Możesz wkleić tu zawartość htaccess lub samą regułkę mod_rewrite, jeśli plik jest duży.

Podanie adresu strony też by ułatwiło sprawę.

Sprawa wygląda tak:

regułka:

RewriteRule ^([A-Za-z_óšężńśłąźćŁ]+)/?$ http://www.krzyzowki.info/trans.php?haslo=$1

W xmlu i na stronie umieszczam takie linki

http://www.krzyzowki.info/mu%B3%B3a czyli link do hasła mułła

na stronie takie linki działają. W FireFox jak wpisuje hasło http://www.krzyzowki.info/mułła to pojawia się w adresie link http://www.krzyzowki.info/mu%B3%B3a i działa. Jak wpisze w IE http://www.krzyzowki.info/mułła

to nie działa, a jak w IE wpisze http://www.krzyzowki.info/mu%B3%B3a to działa. Wszędzie mam ustawione kodowanie iso-8859-2. Możecie cos doradzic ?

Share this post


Link to post
Share on other sites

a sprobuj .* zamiast wymieniania każdego krzaczka.


stopka usunieta z wpoodu wirusa na stronie docelowej

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Terms of Use Privacy Policy